自动备份ros配置到ftp

作者: admin 分类: Ros路由技术 发布时间: 2017-01-10

:log info “开始运行备份脚本….”
:local ftpusername “backup-ros”
:local ftpuserpassword “123456”
:local ftphostname “123456”
:local Port 2121
:log info “获取时间…..”
:local thisdate [/system clock get date]
:local thistime [/system clock get time]
:local datetimestring ([:pick $thisdate 7 11].”-“.[:pick $thisdate 0 3].”-“.[:pick $thisdate 4 6].”-“.$thistime)

:log info “备份文件名字”
:local fname ([/system identity get name].”-“.$datetimestring)

log info “$fname”

log info “开始备份……”
/export file=$fname
:set fname ($fname.”.rsc”)
:log info “系统备份完成…”

:log info “请稍后…!!!”
:delay 2s
:log info “发送备份文件到FTP Server………….”
#”dst-path=”my_ros/”是FTP上的目录 可以自己创建和修改
/tool fetch address=”$ftphostname” dst-path=”my_ros/$fname” src-path=$fname user=”$ftpusername” password=”$ftpuserpassword” port=$Port upload=yes mode=ftp

:log info “删除备份文件”
:delay 1
/file remove “$fname”
:log info “脚本运行成功…!!!!”

如果觉得我的文章对您有用,请随意打赏。您的支持将鼓励我继续创作!

发表评论

电子邮件地址不会被公开。 必填项已用*标注